You are not logged in.

Dear visitor, welcome to Eve of Destruction. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Monday, August 27th 2012, 10:18pm

Help can't connect to server

Today I downloaded and installed the new version (2.5). I only took Part 3 since I already had V2.4 installed.

This is a known issue: If you have Windows 7, the game might crash to desktop while loading map. I had that also before the new update, but could connect after on or two tries. But now with version 2.5 I can't connect to an EOD-server (I only tried hslan-server), even if I try it several times. I did that when the maps "Caen" and "Last man standing" were running, but it always crashed to desktop while loading the map.

My system: WIndows 7 Professional 64-bit --> I had compatibility mode activated (Win Xp SP 3 was standard, but with the new crashes now also tried XP SP 2 and Win98) and of course ran as an administrator.

Creating a Co-Op Lan game did work, but connecting to Hslan server (I only tried this one), did not work :-/ BF 42 patch is also up to date: v.1.61

I guess I could try another server or reinstall everything, but maybe someone has an idea?!

Also another issue: I tried (after years) to create an image from on of the bf1942 CDs, but it didn't work:

Daemon Tools: stops creating image and reports disc errors

Magic Iso: Does start making an image, but progress stays at 0% and cd-drive is inactive

Cd Burner XP: was able to create an image, but if I mount the image on daemon tools, eod/bf 1942 won't start without a real cd in the drive, either..


Any ideas on these problems? Suggestions in English or also German, if you want. And big thanks already!


Monday, August 27th 2012, 10:53pm

Hm, I have absolutely no idea.
Yould could try to reinstall EoD completely. Check if there are any files older than 2012 in your EoD folder.
If so something went wrong.

Image: your CD may be damaged. Try to clean it. You may get a new BF1942 for some cents at ebay :)


Monday, August 27th 2012, 11:02pm

Have you checked that you're really running v2.50?

When I updated v2.40 with the v2.50 installer part3 it managed to update in c:\program files\EA Games\Battlefield 1942\Mods\ where the rest of the game weren't installed
Gruß, Jan


Monday, August 27th 2012, 11:03pm

I also used the incremental update method. My mod folder looks like:…_properties.png

I suggest applying nocd, then NT compatibility and the Disable checkboxes (if you use Aero theme, it tends to steal focus from all classic games)

You may crash once, twice, MAYBE thrice, but it will just iron itself out. 5-10 others I BF1942 with can confirm

No, punkbuster does not care whether you use slow launch (disc usage) or not

EDIT: I just read your second paragraph. I think there is either a conflict in your BF1942 directories (file(s) out of place), or the Part 3 installer did not install to your (x86) folder. Check regular folder



Tuesday, August 28th 2012, 12:39am

Thanks for all the answers. Of course it was easy to solve: Had the same problem as Eisenschwein: I installed it in the wrong wrong folder...... didn't have that one for quite a while :)

Now it works fine again ;)

Cya on the battlefield! :| :thumbsup:


Tuesday, August 28th 2012, 7:17am

!nextvictim :D


Tuesday, August 28th 2012, 9:21pm

LOL :!: